Results 1 to 3 of 3

Thread: Heroic Omnotron Bugged?

  1. #1
    Join Date
    Jan 2010
    Posts
    70

    Heroic Omnotron Bugged?

    So my guild is 10\13, with both heroic nef and cho down (never bothered with Al'Akir), and are progressing on sinestra (gotten into 3rd phase a couple times, hoping to kill this week) so it seems strange that we would have trouble with a fight such as Omnotron. In fact, we usually do not have an issue with it. Sometimes we will wipe a few times from bad luck on combos or someone making a stupid mistake, but usually knock it out between 1 and 4 attempts.

    Last night we were missing our offtank for the first 2 hours of raiding so we decided to go clear out BWD rather than going on to Sinestra. Usually we can do a full BWD clear in right around 2 hours. Instead, we ended up spending 2 hours on Omnotron alone. Some of the wipes were our own fault (the OT we brought isn't bad, but seems to just not be able to handle moving arcano out of puddles and interupting too, so I just took over and made sure I ended up with arcano myself every time), but even once that was straightened out we were having some weird things happening.

    First, early early in the night, on our 2nd or 3rd attempt, we had a string of bad things happen and at 5% all of our dps died from an ooze blowing up on them. We couldn't really figure out how they died from it, as no one that was targeted by ooze died, but we just tried to finish them off. We ended up with myself and 1 healer alive with them at 1%. I was fully topped off, popped my two strongest cooldowns, and hit berserk (bear tank) and right when they hit 100k health they despawned.

    So, that was frustrating, because I would have killed them with 2 mangles, but we went on and just chaulked it up to some weirdness with the oozes. Maybe someone managed to drop threat on a bomb, and the despawning...well they have always been weird about that.

    So as the night went on, we identified one problem that was wiping us on pretty much every decent attempt we had. It is probably not very noticeable for 25 man guilds or most 10 man, as most guilds doing heroics have more ranged than melee. We run with a ret paladin, arms warrior, and mut rogue however, so we cannot rely on our ranged to kill the oozes by themselves every time. Especially when oozes line up with a grip, shadow conductor, etc.

    The issue is this...the oozes are randomly changing targets. No one was feigning, iceblocking, fading, bubbling or anything to drop threat in any way, but at least 70% of our wipes were caused by our melee running out for oozes, then jumping on them when it was clear they were not targeted...only to have the ooze randomly blow up on them at some point before they took it down. In fact, it even happened to me as the tank (I help kill oozes when I get a chance). Oozes spawned, targeted our 3 healers, I charged the last that spawned and had it at 20% then it just randomly blew up and killed me.

    Anyone else notice this? I know they had a small patch this week (few hotfixes and prepping for firelands I guess), but it is really seeming like they broke this fight. We had to put it on normal to kill it, and because of the time we spent on it, didn't even get to drop nef last night.
    Rudolpho, Blackwing's Bane
    Pravus Dei - Bleeding Hollow PVP [Horde]

    http://pravusdei-guild.com/

  2. #2
    Join Date
    Mar 2010
    Posts
    169
    i havent had time to raid lately but i know back when cata first launched i was noticing as a fury warrior when an ooze would get like under 10-15% they had a tendancy to blow up on the melle if the person they were targeting got within like 10 yards of them (which is still way out of there kill radius) so that would be my best guess. way we ended up dealing with it was just having melle pull off the oozes at about 20% but this was all on normal in the first 2-3 weeks of launch so i could be completely wrong

  3. #3
    Join Date
    Jan 2010
    Posts
    70
    Quote Originally Posted by captanmurdoc View Post
    i havent had time to raid lately but i know back when cata first launched i was noticing as a fury warrior when an ooze would get like under 10-15% they had a tendancy to blow up on the melle if the person they were targeting got within like 10 yards of them (which is still way out of there kill radius) so that would be my best guess. way we ended up dealing with it was just having melle pull off the oozes at about 20% but this was all on normal in the first 2-3 weeks of launch so i could be completely wrong
    Yeah, that bug may have just came back. It was not happening until yesterday.
    Rudolpho, Blackwing's Bane
    Pravus Dei - Bleeding Hollow PVP [Horde]

    http://pravusdei-guild.com/

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts