+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 26

Thread: Beware: Frost Aura Ahead

  1. #1
    Join Date
    Jan 2009
    Posts
    27

    Beware: Frost Aura Ahead

    Not sure if anyone has had issues with Sapphiron recently, but this week he sure was a pain to kill. Healers oom before 50% on some tries.

    World of Warcraft - English (NA) Forums -> [BUG] Sapphiron 10-man

  2. #2
    Join Date
    Jan 2009
    Posts
    271
    It's kind of strange how quiet Blizz is being about this.

  3. #3
    Join Date
    Aug 2007
    Posts
    102
    our guild had troubles with saph this week as well.

    Had to bring in a third healer for it again, then one shot it.

  4. #4
    World of Warcraft - English (NA) Forums -> [BUG] Saphiron 10 man

    looks like the new 10-man difficulty is working as intended :/

  5. #5
    Join Date
    Jan 2009
    Posts
    27
    Yikes, for those who wanted a hard mode to weed out pugs/undergeared players I think you just got your wish

    From a Blue poster:

    "It was locked because someone provided an answer in the thread. Specifically, the debuff tooltip indicates that you should be taking damage every second. If that is what is happening, then the safe assumption is that it was broken before, making the encounter too easy. But what you're describing is behavior consistent with the frost aura's tooltip. "

    I have yet to find the provided answer in another thread, has anyone else?

  6. #6
    Join Date
    Aug 2007
    Location
    NSW, Australia
    Posts
    780
    Having read several posts on the issue now I think there is still a bugged element to the fight. One post I saw reported the frost aura ticking more than once every second. If it is bugged it would explain the trouble my group had this week, we even brought in a 25 man geared third healer and we still couldn't get him below 60% before everybody died. He also kept dropping Blizzards on the ice blocks just to rub salt in the wound. Might I add that this group has cleared 10 man Sapphiron with no major issues twice before as well. It should have been easier this week because I was MT and my gear has improved a lot since last week's run.
    Why use big words when a diminutive alternative will suffice?
    http://www.tankspot.com/photoplog/im...nnaxxramas.jpg

  7. #7
    Join Date
    Sep 2007
    Posts
    533
    Weird, done it twice after 3.0.8 and I haven't noticed any difference with damage input or healer mana.

    Edit: Cheers, alt+tab and off we go from cliffs of Azshara....
    Crommi | Archaic Order | Lightning's Blade EU

  8. #8
    Join Date
    Sep 2008
    Posts
    1,909
    Adapt and overcome i say.. a little challenge is good

  9. #9
    Join Date
    Nov 2008
    Posts
    1,675
    We did have a bit of trouble in 10 man (didn't notice it in 25) but I had put it down to the COH/WG nerfs. We switched a hybrid from dps to heal and it was fine from there.

  10. #10
    Join Date
    Nov 2008
    Posts
    10
    My raid had much trouble friday night after several 1 shot attempts in previous weeks. We wrote it off to it being late and us getting sloppy, but it sure felt like something else was at play. I don't have any numbers to back it up, but it did feel like we were dying much faster, and I don't remember the blizzards ever staying on top of the ice blocks like they did almost every time this week. It actually felt like the blizzards were the biggest problem.

  11. #11
    Quote Originally Posted by Gysh View Post
    Yikes, for those who wanted a hard mode to weed out pugs/undergeared players I think you just got your wish

    From a Blue poster:

    "It was locked because someone provided an answer in the thread. Specifically, the debuff tooltip indicates that you should be taking damage every second. If that is what is happening, then the safe assumption is that it was broken before, making the encounter too easy. But what you're describing is behavior consistent with the frost aura's tooltip. "

    I have yet to find the provided answer in another thread, has anyone else?
    Ah, it was a 4-page long thread in the Bug Report forum. Think this one
    World of Warcraft - English (NA) Forums -> [BUG] Sapphiron 10-man

  12. #12
    Join Date
    Oct 2008
    Location
    Belfast
    Posts
    77
    We got our undying last night, no major issues with Saph (or minor ones for that matter)

    /edit Checked our WWS for 10 and 25 man Saph and I can see it's working as the tooltip states. 1200 and 1600 damage per second respectively.
    Last edited by Clav; 02-03-2009 at 03:34 AM.

  13. #13
    Join Date
    Oct 2008
    Posts
    467
    nope we noticed no issues with saph but we are noticing a lot more MC breaks on instructor razuvious 25 man..

    seems anytime anyone sneezes it breaks the MC..

    Same priests doing mc as always have, all hit capped and experienced..cant explain the mc breaking after 0.1 second tho...

    Still managing to adapt and overcome but just a pain for fast clearing now.
    Belgariad: EU : Lightnings Blade. Once a Tank. Always a Tank.

  14. #14
    Join Date
    Mar 2008
    Location
    Bellingham, WA, USA
    Posts
    474
    Maybe it was the healer nerf, or something, but even with Mend pet constantly on my pet i couldnt outheal the frost aura on 10man saphi and my pet keep dying...ended up just doing the fight without it.. lol
    Galushi - 85 Dwarf Warrior - Shadowsong US Alliance.
    Branigan - 85 Goblin Warrior - Kilrogg US Horde.

  15. #15
    Join Date
    Sep 2007
    Posts
    317
    No wonder our raid healing priest was so stressed out and OOMed at 35%, if it hadn't been for our Feral's innervate, we might not have gotten past Sapphiron last week.
    "I played hard to avoid mistakes, but now I can play hard to capitalize on opportunities." -Arold, on the 3.0 Protection Warrior.

  16. #16
    Join Date
    Aug 2007
    Location
    The Poconos
    Posts
    751
    My guild had trouble with Sapphiron this week too. Thanks for posting this

  17. #17
    Join Date
    Jan 2009
    Posts
    27
    Finally someone got a response in the bug forum, now they want a WoW combat log with timestamps to see if the double tick bug actually exists. Looks like he won't accept WWS and such.

    World of Warcraft - English (NA) Forums -> 10-man Saph - This BUG is not a fix.

  18. #18
    Join Date
    Mar 2008
    Posts
    13
    I cannot find the wws from the run but we wiped twice (once with 2 heals the second time with three). The interesting thing was that in the first two times the fight was "working as intended" then in the third attempt it was only ticking every 2 seconds again.

  19. #19
    Join Date
    Oct 2008
    Posts
    18
    They're looking for instances of more than 1 tick per second, which would surely be a bug, but that's not the change I've seen. In prior weeks' 10s, and this week's 25, the aura was doing damage every 2 seconds more often than not. In this week's 10 it was hitting every second, making the fight far more difficult. What's scary is that if 10s is the way it's meant to be, the fight is considerably harder than KT or Maly unless you stack the raid with frost res gear. It seemed quite spot on with the ticks happening every 2 seconds.

    I base my above statement on having a group that killed Maly and 1-shot KT not be able to do Sapph until we swapped out one of the tanks (me) for a 4th healer (also me, gotta love friends who are loose with login info!), and even then it was a very narrow victory.

  20. #20
    Join Date
    Dec 2008
    Posts
    131
    No idea. One shotted him this week for our guild-first kill.

    It's a tense fight by design, but we didn't frost resist at all beyond aura and totem

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts