PDA

View Full Version : Sappharion Question?(10 man)



casperen
02-02-2009, 08:06 AM
Did they change this fight in the last patch? Can't find anything in the patch notes. I noticed that the aggro radius was reduced. Did they make this fight harder?

My guild has downed this boss before without to many issues. This weekend we tried him again and wiped more times than I can count.

The group make up was:

Warr MT
2 Rogues
1 DK Blood
3 Pally heals( one was the OT)
1 druid healer
1 hunter
2 mages

Closest we got was 30%.

We made sure sure to decurse the drain life. It just seemed like the frost damage was taking everyone down so fast, the healers couldn't keep up.

What are we doing wrong? The group we have is all 10man/25 man geared so the gear shouldn't be the issue.

Lore
02-02-2009, 08:48 AM
We 8-manned him on an alt run with only two healers (holy pally/resto shaman) the other night, didn't notice a difference. Having no AOE healing makes the fight pretty hard.

Other than that, onyxia deep breaths more.

greendragonempire
02-02-2009, 08:49 AM
Ony does deep breath more in this patch.

xKhellendrosx
02-02-2009, 08:55 AM
Yeah my guild had some issues with Saph the other night as well, it seems MotW is not enough resist anymore as it didn't seem to help against that 1200 tick. Though we were attempting to 8 man it, but the healers (Holy priest, resto druid) were having issues with mana because of the inc damage.

Jahira
02-02-2009, 09:23 AM
We ran into a few issues with him on our last run. We easily 1 shotted the entire instance with two healers but ended up wiping on him a half dozen times. After doing a bit of digging through combat logs, we discovered:

1: People were taking double ticks from the frost aura.
2: Even after a few people decided to put on max FR gear, they were only getting about 50% resists. In the past this has been about 75%. We don't typically use a ton of FR gear but it seemed like a good idea at the time.

These finding have been confirmed by other raids. There is currently a thread going in the Blizzard Bug Forums. It doesn't appear to be affecting everyone, just certain raid IDs.

casperen
02-02-2009, 03:07 PM
Thanks guys for the response, I did look it up on the bug forums and it does look pretty common. We are going in tonight to try and finish out the run before the reset. Hoping the fixed it already.