PDA

View Full Version : Malygos Phase 3 Bugged?



Bodasafa
01-04-2009, 10:36 PM
Our guild went in last night for Malygos 10-man. Before we had only been able to get slightly into phase 2. But last night we had everything clicking and got to phase 3 , three times.

Problem was each time we got into phase 3, no one was able to use the shield ability. We all had a range of different mods to use action bars and even a few people that used the default blizzard UI. All with the same result, not one of us were able to use the shield and we wiped each time.

And yes we had enough energy to use the ability.

I put in a GM ticket to ask if there were any known issues. Still waiting for a response, but Im wondering if anyone else has seen similar issues?

Im on Eldre' Thalas btw, if that matters.

Nightdemon
01-04-2009, 10:43 PM
It not only requires energy, but also a combo point. Sure you had the combo-point up for it?

Rak
01-04-2009, 10:52 PM
Don't target the boss when you're falling onto the drakes.

Giggitygigs
01-05-2009, 07:07 AM
Don't target the boss when you're falling onto the drakes.
Is this confirmed? A few of our people were having this problem last night in 25-man last night(we still downed him anyways), didn't even figure this into the equation. Would refreshing your target fix this?(switching targets, or hitting escape to drop target and then retarget?)

Ray
01-05-2009, 09:03 AM
Confirmed on the bug forums along with the raid&dungeon forum.

We were wiping over and over in the 25 man because most people couldnt use the shield and some people got it to work and no one knew why. Someone finally checked the forums and found the bug report.

All you have to do is deselect the boss as your falling to your drake and not target him until you are in position to start attacking and your shield will work just fine.

We litterally 1 shot him after finding the bug report. GG blizz

Bodasafa
01-05-2009, 04:38 PM
Thank you for the info.